Issue with email deliverability

Incident Report for Stonly

Resolved

Our email provider informed us that the issue should be fully resolved.
Posted Apr 14, 2025 - 14:38 UTC

Monitoring

Our email provider informed us that the issue should be resolved. We will now enter the monitoring phase and will update once we have confirmation that it's completely resolved.
Posted Apr 14, 2025 - 13:17 UTC

Investigating

We are experiencing a delay in email delivery due to an outage with our third-party email provider. The provider is aware of the situation and is actively working on a resolution. We will update our status page once the issue is confirmed to be resolved.
Posted Apr 14, 2025 - 10:12 UTC
This incident affected: Stonly Contact Forms.